Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Delays in SIM Status Changes
Incident Report for Twilio
Resolved
All systems are functional.
Posted 5 months ago. Sep 09, 2018 - 10:57 PDT
Investigating
Changes made to Programmable Wireless SIM status for SIMs managed through the T-Mobile USA network are delayed due to a carrier issue. We are working with the carrier to resolve the problem and will provide additional information as it becomes available.
Posted 5 months ago. Sep 09, 2018 - 08:35 PDT
This incident affected: PROGRAMMABLE WIRELESS.