Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delays to Movistar and AT&T in Mexico
      Incident Report for Twilio
      Resolved
      We are no longer experiencing the issue of SMS delivery delays when sending messages to Movistar and AT&T in Mexico. This incident has been resolved.
      Posted May 25, 2023 - 00:47 PDT
      Monitoring
      We have observed a recovery from the SMS delivery delays when sending messages to Movistar and AT&T in Mexico. We are monitoring the service to ensure a full recovery, and we will provide another update in 2 hours or as soon as more information becomes available.
      Posted May 24, 2023 - 22:55 PDT
      Update
      We continue to experience SMS delivery delays when sending messages to Movistar and AT&T in Mexico. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted May 24, 2023 - 21:10 PDT
      Update
      We are experiencing SMS delivery delays when sending messages to Movistar and AT&T in Mexico. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted May 24, 2023 - 20:25 PDT
      Investigating
      Our monitoring systems have detected a potential issue with SMS delivery delays. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted May 24, 2023 - 20:07 PDT
      This incident affected: CARRIER NETWORK (SMS, Latin America).