Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
US Long Code MMS delivery report (DLR) failures for Sprint & T-Mobile handsets
Incident Report for Twilio
Resolved
All systems are operating normally.
Posted 9 months ago. Sep 29, 2018 - 14:23 PDT
Investigating
MMS messages sent from US Long Codes towards Sprint & T-Mobile USA handsets are experiencing delivery report (DLR) failures. We are working with our carrier partner to resolve the issue and will provide additional information as it becomes available.
Posted 9 months ago. Sep 29, 2018 - 12:37 PDT