Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Delayed Billed Amount Reporting For Programmable Wireless Usage API
Incident Report for Twilio
Resolved
The incident regarding delayed billing amount reporting with Programmable Wireless Usage APIs has been resolved and the Programmable Wireless Usage APIs are operating normally at this time.
Posted Oct 14, 2021 - 17:16 PDT
Monitoring
Billing reporting when using the Programmable Wireless Usage APIs is now operating normally. We will continue to monitor for system stability. We'll provide another update in 30 minutes or as soon as more information becomes available.
Posted Oct 14, 2021 - 16:43 PDT
Update
We continue to experience delayed bill amount reporting with Programmable Wireless Usage APIs. Customers querying Usage records via the Usage APIs may experience inconsistent results with the billed amount values returned. This is only affecting the reported period for the month of October. We will provide another update in 16 hours or as soon as more information becomes available.
Posted Oct 14, 2021 - 15:36 PDT
Update
We continue to experience delayed bill amount reporting with Programmable Wireless Usage APIs. Customers querying Usage records via the Usage APIs may experience inconsistent results with the billed amount values returned. This is only affecting the reported period for the month of October. We will provide another update in 8 hours or as soon as more information becomes available.
Posted Oct 14, 2021 - 07:36 PDT
Update
We continue to experience delayed bill amount reporting with Programmable Wireless Usage APIs. Customers querying Usage records via the Usage APIs may experience inconsistent results with the billed amount values returned. This is only affecting the reported period for the month of October. We will provide another update in 4 hours or as soon as more information becomes available.
Posted Oct 14, 2021 - 03:54 PDT
Update
We continue to experience delayed bill amount reporting with Programmable Wireless Usage APIs. Customers querying Usage records via the Usage APIs may experience inconsistent results with the billed amount values returned. This is only affecting the reported period for the month of October. We will provide another update in 2 hour or as soon as more information becomes available.
Posted Oct 14, 2021 - 01:54 PDT
Investigating
We are experiencing delayed bill amount reporting with Programmable Wireless Usage APIs. Customers querying Usage records via the Usage APIs may experience inconsistent results with the billed amount values returned. This is only affecting the reported period for the month of October. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Oct 14, 2021 - 00:55 PDT
This incident affected: INTERNET OF THINGS (Programmable Wireless) and TWILIO PLATFORM (Billing).