Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS DLR Delays to Airtel in Bangladesh
      Incident Report for Twilio
      Resolved
      We are no longer experiencing SMS DLR delays when sending messages to Airtel in Bangladesh. This incident has been resolved.
      Posted Feb 28, 2020 - 12:48 PST
      Update
      Our engineers are still investigating SMS DLR delays when sending messages to Airtel in Bangladesh with the underlying carrier. We will share more updates as soon as they become available.
      Posted Feb 28, 2020 - 10:57 PST
      Update
      Our engineers are still investigating this issue with the underlying carrier. We will share more updates as soon as they become available.
      Posted Feb 28, 2020 - 06:10 PST
      Update
      Our engineers are still investigating this issue with the underlying carrier. We will share more updates as soon as they become available.
      Posted Feb 28, 2020 - 03:09 PST
      Investigating
      We are experiencing SMS DLR delays when sending messages to Airtel in Bangladesh. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
      Posted Feb 28, 2020 - 01:55 PST
      This incident affected: CARRIER NETWORK (SMS, APAC).