Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Calls failing to Twilio Cyprus phone numbers
Incident Report for Twilio
Resolved
This incident has been resolved.
Posted 18 days ago. Jul 01, 2019 - 15:05 PDT
Update
We continue to have issues with calls to Cyprus failing, and we continue to work closely with our carrier partner to resolve this issue. We will let you know as soon as we have more information.
Posted 18 days ago. Jul 01, 2019 - 11:55 PDT
Identified
Our monitoring systems have Identified that calls to Twilio phone numbers in Cyprus are failing. Our engineers are working with our carrier partner to resolve this issue and will provide more information as soon as available.
Posted 19 days ago. Jul 01, 2019 - 03:53 PDT
This incident affected: CARRIER NETWORK (Voice, Europe).