Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Zipwhip Gateway
      Issues related to Zipwhip's Services
        Scheduled maintenance
        System Metrics

        SMS Delivery Delays to Timor Telecom Network in Timor Leste

        Incident Report for Twilio

        Resolved

        We continue to face SMS delivery delays when sending messages to the Timor Telecom Network in Timor Leste. We will contact the impacted customers individually to provide further updates and concerns related to this particular degradation. We will resolve this post.
        Posted Apr 15, 2024 - 13:07 PDT

        Update

        We are continuing to experience SMS delivery delays when sending messages to the Timor Telecom Network in Timor Leste. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 24 hours or as soon as more information becomes available.
        Posted Apr 14, 2024 - 13:47 PDT

        Update

        We are continuing to experience SMS delivery delays when sending messages to the Timor Telecom Network in Timor Leste. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 24 hours or as soon as more information becomes available.
        Posted Apr 13, 2024 - 13:52 PDT

        Update

        We are continuing to experience SMS delivery delays when sending messages to the Timor Telecom Network in Timor Leste. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 24 hours or as soon as more information becomes available.
        Posted Apr 12, 2024 - 13:51 PDT

        Update

        We are continuing to experience SMS delivery delays when sending messages to the Timor Telecom Network in Timor Leste. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 24 hours or as soon as more information becomes available.
        Posted Apr 11, 2024 - 13:52 PDT

        Update

        We are continuing to experience SMS delivery delays when sending messages to the Timor Telecom Network in Timor Leste. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 24 hours or as soon as more information becomes available.
        Posted Apr 10, 2024 - 14:02 PDT

        Update

        We are continuing to experience SMS delivery delays when sending messages to the Timor Telecom Network in Timor Leste. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 24 hours or as soon as more information becomes available.
        Posted Apr 09, 2024 - 14:13 PDT

        Update

        We are continuing to experience SMS delivery delays when sending messages to the Timor Telecom Network in Timor Leste. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 24 hours or as soon as more information becomes available.
        Posted Apr 08, 2024 - 14:20 PDT

        Update

        We are continuing to experience SMS delivery delays when sending messages to the Timor Telecom Network in Timor Leste. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 24 hours or as soon as more information becomes available.
        Posted Apr 07, 2024 - 14:34 PDT

        Update

        We still continue to experience SMS delivery delays when sending messages to the Timor Telecom Network in Timor Leste. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 24 hours or as soon as more information becomes available.
        Posted Apr 06, 2024 - 14:34 PDT

        Update

        We still continue to experience SMS delivery delays when sending messages to the Timor Telecom Network in Timor Leste. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 16 hours or as soon as more information becomes available.
        Posted Apr 05, 2024 - 22:35 PDT

        Investigating

        We continue to experience SMS delivery delays when sending messages to the Timor Telecom Network in Timor Leste. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 8 hours or as soon as more information becomes available.
        Posted Apr 05, 2024 - 14:02 PDT

        Update

        We continue to experience SMS delivery delays when sending messages to Timor Telecom Network in Timor Leste. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
        Posted Apr 05, 2024 - 10:04 PDT

        Monitoring

        We continue to experience SMS delivery delays when sending messages to Timor Telecom Network in Timor Leste. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
        Posted Apr 05, 2024 - 10:02 PDT

        Update

        We continue to experience SMS delivery delays when sending messages to Timor Telecom Network in Timor Leste. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
        Posted Apr 05, 2024 - 08:27 PDT

        Update

        We are experiencing SMS delivery delays when sending messages to Timor Telecom Network in Timor Leste. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
        Posted Apr 05, 2024 - 07:32 PDT

        Investigating

        We are currently experiencing SMS delivery delays when sending messages to the Timor Telecom Network in Timor Leste. Our engineers are actively collaborating with our carrier partner to address this issue. We anticipate providing another update within four hours or as soon as more information becomes available.
        Posted Apr 05, 2024 - 07:03 PDT
        This incident affected: CARRIER NETWORK (SMS, APAC).