Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS to Excelcom customers in Indonesia is currently degraded
      Incident Report for Twilio
      Resolved
      This incident has been resolved
      Posted Sep 14, 2018 - 23:07 PDT
      Monitoring
      SMS to Excelcom customers in Indonesia is currently stable. Our engineers are currently monitoring the traffic and we will provide an update shortly
      Posted Sep 14, 2018 - 22:29 PDT
      Investigating
      SMS to Excelcom customers in Indonesia is currently degraded. We are working with our carrier partners for more information on this incident.
      Posted Sep 14, 2018 - 20:10 PDT
      This incident affected: PROGRAMMABLE MESSAGING (SMS).