Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Delays in email delivery.
      Incident Report for Twilio
      Resolved
      Email messages from Twilio are working normally at this time.
      Posted Sep 06, 2017 - 15:04 PDT
      Identified
      Email messages for password resets, Debugger alerts, usage triggers, and other automated email messages originating from Twilio may be delayed. Our engineering team is investigating the issue.
      Posted Sep 06, 2017 - 14:09 PDT
      This incident affected: DEVELOPER TOOLS (Console).