Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Programmable Messaging Status Callbacks Delayed
Incident Report for Twilio
Resolved
We are no longer experiencing status callback delays for the Programmable Messaging API. This incident has been resolved.
Posted Jul 27, 2021 - 10:22 PDT
Monitoring
We are observing recovery for the issue affecting status callback delays for the Programmable Messaging API. We will continue monitoring the service to ensure a full recovery. We will provide another update in 30 minutes or as soon as more information becomes available.
Posted Jul 27, 2021 - 09:54 PDT
Update
We are currently investigating status callback delays for the Programmable Messaging API. Our engineers are working on the issue, and we will provide another update in 1 hour or as soon as more information becomes available.
Posted Jul 27, 2021 - 09:27 PDT
Investigating
Our monitoring systems have detected a potential issue with Messaging Callbacks. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Jul 27, 2021 - 09:14 PDT
This incident affected: PROGRAMMABLE MESSAGING (MMS, SMS, Messaging Channels, Messaging Insights).