Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
MMS Delivery Reporting Delays to US Carriers from a Subset of Shortcodes
Incident Report for Twilio
Resolved
We are no longer experiencing MMS delivery delays to US Carriers from a subset of shortcodes. This incident has been resolved.
Posted Nov 25, 2021 - 00:12 PST
Update
We are no longer experiencing MMS delivery delays to US Carriers from a subset of shortcodes. This incident has been resolved.
Posted Nov 25, 2021 - 00:11 PST
Monitoring
The issue with MMS delivery delays to US Carriers from a subset of shortcodes is now operating normally. We will continue to monitor for system stability. We'll provide another update in 2 hours or as soon as more information becomes available.
Posted Nov 24, 2021 - 22:10 PST
Update
We are still experiencing MMS delivery delays to US carriers from a subset of shortcodes. Our engineers are working with our carrier partner to resolve this issue. We expect to provide another update in 4 hours or as soon as more information becomes available.
Posted Nov 24, 2021 - 19:47 PST
Update
We are still experiencing MMS delivery delays to US Carriers from a subset of shortcodes. Our engineers are working with our carrier partner to resolve this issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Nov 24, 2021 - 17:47 PST
Update
We are experiencing MMS delivery delays to US Carriers from a subset of shortcodes. Our engineers are working with our carrier partner to resolve this issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Nov 24, 2021 - 15:56 PST
Update
We are continuing to investigate this issue.
Posted Nov 24, 2021 - 15:39 PST
Investigating
Our monitoring systems have detected a potential issue with MMS delivery reporting delays to US Carriers from a subset of shortcodes. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Nov 24, 2021 - 15:38 PST
This incident affected: CARRIER NETWORK (MMS Long Code, North America) and PROGRAMMABLE MESSAGING (MMS).