Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Carriers around the world are experiencing capacity issues because of increased demand on their networks due to COVID-19. This may result in voice quality issues, busy signals, or other errors on your phone calls. Twilio continues to monitor the health of the global carrier networks and we are publishing the most up-to-date information on our Worldwide Telephony Network Congestion page.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Outbound call failures to UK Mobile O2 network
Incident Report for Twilio
Resolved
This incident has been resolved.
Posted Mar 18, 2020 - 18:49 PDT
Update
We are continuing to work with our carrier partner to resolve the issue. We will provide further updates as the information becomes available.
Posted Mar 18, 2020 - 18:38 PDT
Update
We are continuing to work with our carrier partner to resolve the issue. We will provide further updates as the information becomes available.
Posted Mar 18, 2020 - 12:51 PDT
Update
We are continuing to work with our carrier partner to resolve the issue. We will provide further updates as the information becomes available.
Posted Mar 18, 2020 - 07:15 PDT
Investigating
We are observing some outbound call failures to O2 network destinations in UK. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as more information becomes available.
Posted Mar 18, 2020 - 06:19 PDT
This incident affected: CARRIER NETWORK (Voice, Europe).