We are now observing full recovery with Lookup v2 that was resulting in high latency responses for requests in some countries. The issue has been resolved and the service is functioning normally at this time.
Posted Sep 23, 2025 - 09:37 PDT
Update
We continue to observe recovery with Lookup v2 resulting in high latency responses for requests in some countries but are not seeing complete stability. We expect to provide another update in 30 minutes or as soon as more information becomes available.
Posted Sep 23, 2025 - 09:33 PDT
Monitoring
We are observing recovery with Lookup v2 resulting in high latency responses for requests in some countries. We expect to provide another update in 30 minutes or as soon as more information becomes available.
Posted Sep 23, 2025 - 09:01 PDT
Update
We are still experiencing issues in relation to Lookup v2 where packages with SMS Pumping Risk and Line Type Intelligence are presenting high latency responses for requests in some countries. We expect to provide another update in 4 hours or as soon as more information becomes available.
Posted Sep 23, 2025 - 07:44 PDT
Update
We are still experiencing issues in relation to Lookup v2 where packages with SMS Pumping Risk and Line Type Intelligence are presenting high latency responses for requests in some countries. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Sep 23, 2025 - 05:43 PDT
Investigating
We are experiencing issues in relation to Lookup v2 where packages with SMS Pumping Risk and Line Type Intelligence are presenting high latency responses for requests in some countries. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Sep 23, 2025 - 04:51 PDT
This incident affected: ACCOUNT SECURITY (Lookup).