Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delays to Multiple Small Networks in the US for a Subset of Short and Long Codes
      Incident Report for Twilio
      Resolved
      We are no longer experiencing SMS delivery delays when sending messages to multiple small networks in the US for a subset of short and long codes. This incident has been resolved.
      Posted Jul 24, 2024 - 05:52 PDT
      Update
      We are observing recovery in SMS delivery delays when sending messages to multiple small networks in the US for a subset of short and long codes. We will monitor the services to ensure a full recovery and will provide another update in 2 hours or as soon as more information becomes available.
      Posted Jul 24, 2024 - 03:57 PDT
      Update
      We are observing recovery in SMS delivery delays when sending messages to multiple small networks in the US for a subset of short and long codes. We will monitor the services to ensure a full recovery and will provide another update in 2 hours or as soon as more information becomes available.
      Posted Jul 24, 2024 - 01:55 PDT
      Monitoring
      We are observing recovery in SMS delivery delays when sending messages to multiple small networks in the US for a subset of short and long codes. We will monitor the services to ensure a full recovery and will provide another update in 2 hours or as soon as more information becomes available.
      Posted Jul 23, 2024 - 23:56 PDT
      Update
      We are still experiencing SMS delivery delays when sending messages to multiple small networks in the US for a subset of short and long codes. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 8 hours or as soon as more information becomes available.
      Posted Jul 23, 2024 - 22:03 PDT
      Update
      We are still experiencing SMS delivery delays when sending messages to multiple small networks in the US for a subset of short and long codes. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 4 hours or as soon as more information becomes available.
      Posted Jul 23, 2024 - 18:17 PDT
      Update
      We are still experiencing SMS delivery delays when sending messages to multiple small networks in the US for a subset of short and long codes. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Jul 23, 2024 - 16:23 PDT
      Investigating
      We are experiencing MMS/SMS delivery delays when sending messages to multiple small networks in the US for a subset of short and long codes. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Jul 23, 2024 - 15:23 PDT
      This incident affected: CARRIER NETWORK (SMS Long Code, North America, SMS Short Code, North America).