Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Inbound calls failing to some NL, FR, IE, BE phone numbers
Incident Report for Twilio
Resolved
This incident has been resolved.
Posted 7 months ago. Nov 29, 2018 - 16:08 PST
Monitoring
We are starting to see recovery in inbound calls to Twilio phone numbers across Ireland, France, Belgium and the Netherlands. We will continue to monitor to ensure there are no further problems.
Posted 7 months ago. Nov 29, 2018 - 15:42 PST
Investigating
We have detected an increase in failures for inbound calls to some Twilio phone numbers in Ireland, France, Belgium, and the Netherlands. Our engineers are working with our carrier partner to resolve this issue and will provide more information as soon as available.
Posted 7 months ago. Nov 29, 2018 - 15:10 PST
This incident affected: PROGRAMMABLE VOICE (PSTN).