Our engineers have implemented a fix for the issue with the account balance and are monitoring system performance. We will provide another update in 30 minutes or as soon as more information becomes available.
Posted Mar 18, 2026 - 23:19 PDT
Update
Our engineers have implemented a fix for the issue with the account balance and are monitoring system performance. We will provide another update in 30 minutes or as soon as more information becomes available.
Posted Mar 18, 2026 - 22:48 PDT
Monitoring
Our engineers have implemented a fix for the issue with the account balance and are monitoring system performance. We will provide another update in 30 minutes or as soon as more information becomes available.
Posted Mar 18, 2026 - 22:19 PDT
Identified
Our engineers have identified the issue with the account balance and are working to deploy a fix. We expect to provide another update in 8 hours or as soon as more information becomes available.
Posted Mar 18, 2026 - 15:10 PDT
Update
An account balance adjustment activity was performed by our team for inactive and old accounts, this resulted in charging some of our customer credit cards inadvertently. Our team is working on invalidating those transactions. We will provide another update in 4 hours or as soon as more information becomes available.
Posted Mar 18, 2026 - 09:58 PDT
Investigating
An account balance adjustment activity was performed by our team for inactive and old accounts, this resulted in charging some of our customer credit cards inadvertently. Our team is working on invalidating those transactions. We will provide another update in 2 hour or as soon as more information becomes available.
Posted Mar 18, 2026 - 07:57 PDT
This incident affected: TWILIO PLATFORM (Billing).