Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Report Delays To The Philippines Over Philippine Local Longcode
      Incident Report for Twilio
      Resolved
      This incident has been resolved.
      Posted Feb 13, 2020 - 00:54 PST
      Update
      We are continuing to work with our Carrier Partner to resolve. We will update when we have new information to provide.
      Posted Feb 12, 2020 - 21:55 PST
      Investigating
      We are experiencing delays in receiving delivery reports for messages submitted with Twilio Philippine local long code to Philippine handsets. We are working with our carrier partners to resolve the issue and would provide further updates as soon as they become available.
      Posted Feb 12, 2020 - 20:01 PST
      This incident affected: CARRIER NETWORK (SMS, APAC).