Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delays to AT&T US With Programmable Messaging, Verify and Authy
      Incident Report for Twilio
      Resolved
      We are no longer experiencing SMS delivery delays when sending messages to AT&T US with Verify and Authy. This incident has been resolved.
      Posted Jan 15, 2022 - 03:07 PST
      Update
      We are no longer experiencing delivery delays when sending messages to AT&T US with Verify and Authy. For Programmable Messaging, we are observing recovery in SMS delivery delays via Long codes, Toll Free and a subset of short codes. However, we are still experiencing SMS delivery delays for a subset of short codes. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 4 hours or as soon as more information becomes available.
      Posted Jan 14, 2022 - 23:09 PST
      Update
      We are observing recovery in SMS delivery delays when sending messages to AT&T US with Verify and Authy. For Programmable Messaging, we are observing recovery in SMS delivery delays via Long codes, Toll Free and a subset of short codes. However, we are still experiencing SMS delivery delays for a subset of short codes. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 4 hours or as soon as more information becomes available.
      Posted Jan 14, 2022 - 22:39 PST
      Update
      We are still experiencing SMS delivery delays when sending messages to AT&T US with Programmable Messaging, Verify and Authy. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Jan 14, 2022 - 20:36 PST
      Update
      We are experiencing SMS delivery delays when sending messages to AT&T US with Programmable Messaging, Verify and Authy. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Jan 14, 2022 - 19:36 PST
      Investigating
      We are experiencing SMS delivery delays when sending messages to AT&T US. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Jan 14, 2022 - 18:58 PST
      This incident affected: CARRIER NETWORK (SMS Long Code, North America, SMS Short Code, North America, SMS Toll-Free, North America) and ACCOUNT SECURITY (Authy 2FA, Verify).