Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Messages Failures Over A2P to T-Mobile
      Incident Report for Twilio
      Resolved
      We are no longer experiencing SMS delivery failures to a subset of messages sent over A2P to T-Mobile. This incident has been resolved.
      Posted Jan 20, 2023 - 13:55 PST
      Monitoring
      We are observing recovery in message delivery failures for a subset of messages sent over A2P to T-Mobile. We will continue to monitor to ensure full service recovery. We expect to provide another update in 30 minutes or as soon as more information becomes available.
      Posted Jan 20, 2023 - 13:38 PST
      Update
      We continue to investigate an issue causing message delivery failures for a subset of messages sent over A2P to T-Mobile. We expect to provide another update in 2 hours or as soon as more information becomes available.
      Posted Jan 20, 2023 - 12:11 PST
      Update
      We are investigating an issue causing message delivery failures for a subset of messages sent over A2P to T-Mobile. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Jan 20, 2023 - 11:23 PST
      Investigating
      Our monitoring systems have detected a potential issue with A2P. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Jan 20, 2023 - 11:07 PST
      This incident affected: PROGRAMMABLE MESSAGING (SMS).