Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delays to MTN in South Africa via Domestic Pre-Registered Sender ID
      Incident Report for Twilio
      Resolved
      We are no longer experiencing SMS Delivery Delays to MTN in South Africa via Domestic Pre-Registered Sender IDs. This incident has been resolved.
      Posted Oct 22, 2024 - 13:15 PDT
      Monitoring
      We are observing recovery in SMS Delivery Delays to MTN in South Africa 655-10 via Domestic Pre-Registered Sender ID. We will continue monitoring the service to ensure a full recovery. Another update will be provided in 2 hours or as soon as more information becomes available.
      Posted Oct 22, 2024 - 11:15 PDT
      Update
      We continue to investigate the issue causing SMS Delivery Delays to MTN in South Africa 655-10 via Domestic Pre-Registered Sender ID. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
      Posted Oct 22, 2024 - 09:16 PDT
      Update
      We are experiencing SMS Delivery Delays to MTN in South Africa 655-10 via Domestic Pre-Registered Sender ID. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Oct 22, 2024 - 08:14 PDT
      Investigating
      Our monitoring systems have detected a potential issue of SMS Delivery Delays to MTN in South Africa 655-10 via Domestic Pre-Registered Sender ID. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Oct 22, 2024 - 08:08 PDT
      This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).