Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery delays towards Airtel Nigeria
      Incident Report for Twilio
      Resolved
      This incident has been resolved.
      Posted Mar 23, 2020 - 23:27 PDT
      Monitoring
      We are observing signs of recovery with SMS delivery to the Airtel network in Nigeria. We will continue to monitor to ensure a full recovery.
      Posted Mar 23, 2020 - 22:34 PDT
      Update
      Our engineers are still working on this issue with the carrier partner. We will provide more updates as soon as they become available.
      Posted Mar 23, 2020 - 19:29 PDT
      Investigating
      We are observing message delivery delays for our SMS sent to Airtel in the Nigeria. We are working with our carrier partners to resolve the issue and will provide an update as soon as we have more information
      Posted Mar 23, 2020 - 18:14 PDT