Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Small number of Chrome 45 calls failing to complete ICE negotiation.
      Incident Report for Twilio
      Resolved
      At 2:25pm on September 18, our engineering team deployed an update of the twilio.js library that resolves the intermittent call drop issue identified in Chrome 45. The root cause of the issue was a change in the PeerConnection state machine in the Chrome 45 release. The new library handles this change, and our metrics show that the issue has not reoccurred since the new library was deployed. Please contact Twilio Support if you have any questions.
      Posted Sep 18, 2015 - 22:21 PDT
      Update
      Our engineers have identified that the root cause of the intermittent dropped calls in Chrome 45 is due to a low-level change in the WebRTC state machine, and are working on a modification to twilio.js to accommodate this change and eliminate the dropped call issue . We estimate that we will have the updated twilio.js library in testing tomorrow morning, 9/18, with the possibility of deploying it to production if all tests pass by the afternoon the same day. We will next update this status page when the updated library is deployed.
      Posted Sep 17, 2015 - 22:13 PDT
      Update
      We are continuing to work internally and with partners at Google to correct this issue. On September 15 we completed rollout of additional logging in Twilio Client's twilio.js library. These changes complement the server-side logging we deployed on September 14, and should allow us to collect the data required to identify the root cause. Customers who are experiencing intermittent dropped calls (estimated to impact fewer than 3% of all calls) should use Firefox in the interim.
      Posted Sep 16, 2015 - 09:30 PDT
      Update
      We have added additional logging capabilities to track down the issue and filed a ticket with Google.
      Posted Sep 15, 2015 - 13:43 PDT
      Identified
      We have identified that between 1-3% of calls made from Chrome 45 are failing to complete ICE negotiation, leading to call failure. Our engineering team is working on a workaround or fix for the issue. In the interim, Firefox does not appear to have the same problem and can be used as an alternative.
      Twilio engineering will provide regular updates on this page.
      Posted Sep 14, 2015 - 08:24 PDT