Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Programmable Wireless Usage APIs Returning Elevated Rate of 500 Errors
Incident Report for Twilio
Resolved
The issue causing missing data from the Programmable Wireless Usage API has been resolved and the Programmable Wireless Usage API is operating normally at this time. This incident is resolved.
Posted Jan 13, 2022 - 08:26 PST
Monitoring
The Programmable Wireless Usage API is now operating normally. The API is no longer missing data including the per SIM spending page in console. We will continue to monitor to ensure system stability and provide another update in 2 hours or as soon as more information becomes available.
Posted Jan 13, 2022 - 06:30 PST
Update
We continue to see recovery for the issue causing the Programmable Wireless Usage API to return elevated HTTP errors. Data usage reporting for the Programmable Wireless is now back to normal, however the per SIM spending page on console may still show empty resultsfor some customers. Our engineering team is actively working on full resolution. We will provide another update in 24 hours or as soon as more information becomes available.
Posted Jan 12, 2022 - 15:06 PST
Update
We continue to see recovery for the issue causing the Programmable Wireless Usage API to return elevated HTTP errors. Data usage reporting for the Programmable Wireless will still be delayed via the Usage APIs. We are not experiencing 500 errors anymore. Our engineering team is actively working on full resolution. We will provide another update in 24 hours or as soon as more information becomes available.
Posted Jan 11, 2022 - 22:30 PST
Update
We continue to see recovery for the issue causing the Programmable Wireless Usage API to return elevated HTTP errors. Data usage reporting for the Programmable Wireless will still be delayed via the Usage APIs. We are not experiencing 500 errors anymore. Our engineering team is actively working on full resolution. We will provide another update in 24 hours or as soon as more information becomes available.
Posted Jan 10, 2022 - 22:30 PST
Update
We continue to see recovery for the issue causing the Programmable Wireless Usage API to return elevated HTTP errors. Data usage reporting for the Programmable Wireless will still be delayed via the Usage APIs. We are not experiencing 500 errors anymore. Our engineering team is actively working on full resolution. We will provide another update in 24 hours or as soon as more information becomes available.
Posted Jan 09, 2022 - 22:42 PST
Update
We continue to see recovery for the issue causing the Programmable Wireless Usage API to return elevated HTTP errors. Data usage reporting for the Programmable Wireless will still be delayed via the Usage APIs. We are not experiencing 500 errors anymore. Our engineering team is actively working on full resolution. We will provide another update in 16 hours or as soon as more information becomes available.
Posted Jan 09, 2022 - 06:42 PST
Update
We continue to see recovery for the issue causing the Programmable Wireless Usage API to return elevated HTTP errors. New updates for the Programmable Wireless Usage API will still see delays. Our engineering team is actively working on full resolution. We will provide another update in 16 hours or as soon as more information becomes available.
Posted Jan 09, 2022 - 06:30 PST
Update
We continue to see recovery for the issue causing the Programmable Wireless Usage API to return elevated HTTP errors. New updates for the Programmable Wireless Usage API will still see delays. Our engineering team is actively working on full resolution. We will provide another update in 8 hours or as soon as more information becomes available.
Posted Jan 08, 2022 - 22:35 PST
Update
We continue to see recovery for the issue causing the Programmable Wireless Usage API to return elevated HTTP errors. New updates for the Programmable Wireless Usage API will still see delays. Our engineering team is actively working on full resolution. We will provide another update in 4 hours or as soon as more information becomes available.
Posted Jan 08, 2022 - 18:33 PST
Update
We continue to see recovery for the issue causing the Programmable Wireless Usage API to return elevated HTTP errors. New updates for the Programmable Wireless Usage API will still see delays. Our engineering team is actively working on full resolution. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Jan 08, 2022 - 16:33 PST
Identified
The issue causing the Programmable Wireless Usage API to return elevated HTTP errors has been identified, and is starting to see recovery. New updates for the Programmable Wireless Usage API will still see delays. Our engineering team is actively working on full resolution. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Jan 08, 2022 - 15:34 PST
Update
We are continuing to investigate elevated HTTP 500 error rates for the Programmable Wireless Usage API. The elevated error rates may result in 500 errors for usage requests for a subset of customers, as well as new updates for Programmable Wireless usage. We will provide another update in 4 hours or as soon as more information becomes available.
Posted Jan 08, 2022 - 14:13 PST
Update
We are continuing to investigate elevated HTTP 500 error rates for the Programmable Wireless Usage API. The elevated error rates may result in 500 errors for usage requests for a subset of customers, as well as new updates for Programmable Wireless usage. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Jan 08, 2022 - 12:12 PST
Update
We are experiencing elevated HTTP 500 error rates for the Programmable Wireless Usage API. The elevated error rates may result in 500 errors for usage requests for a subset of customers, as well as new updates for Programmable Wireless usage. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Jan 08, 2022 - 11:13 PST
Investigating
Our monitoring systems have detected a potential issue with Programmable Wireless Usage APIs. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Jan 08, 2022 - 10:58 PST
This incident affected: INTERNET OF THINGS (Programmable Wireless).