Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Issue With Task Router REST API
      Incident Report for Twilio
      Resolved
      The REST API headers formatting has been fixed, and TaskRouter is operating normally at this time. This incident has been resolved.
      Posted Jun 29, 2022 - 13:02 PDT
      Monitoring
      Our engineering team has deployed a fix, and now the TaskRouter REST API headers formatting has been fixed. We will continue to monitor for system stability. We’ll provide another update in 30 minutes or as soon as more information becomes available.
      Posted Jun 29, 2022 - 12:32 PDT
      Update
      We are investigating an issue with TaskRouter REST API headers that were previously being returned in uppercase are now being returned in lowercase, breaking some customer workflows. This can include monitoring rate-limit assumption and protecting task and worker skills. We expect to provide another update in 30 minutes or as soon as more information becomes available.
      Posted Jun 29, 2022 - 12:03 PDT
      Investigating
      Our monitoring systems have detected a potential issue with Task Router. Public API Headers being returned in lowercase. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Jun 29, 2022 - 11:40 PDT
      This incident affected: FLEX (TaskRouter).