Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Devices Using Super SIM May Experience Delays In Connecting with 2G and 3G
Incident Report for Twilio
Resolved
The 2G and 3G connectivity issue impacting devices using Super SIM has been resolved and Super SIM is operating normally at this time.
Posted Sep 16, 2020 - 00:16 PDT
Monitoring
Devices using Super SIM in connecting with 2G and 3G are now operating normally. We will continue to monitor the situation before we mark the incident as fully resolved.
Posted Sep 15, 2020 - 22:11 PDT
Update
Our monitoring systems have triggered an investigation into potential issues connecting on 2G or 3G radio access technologies. Our engineering team has been alerted and is actively investigating. We will update you in 1 hour or as soon as we have more information.
Posted Sep 15, 2020 - 21:51 PDT
Update
Our monitoring systems have detected a potential issue. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Sep 15, 2020 - 21:43 PDT
Investigating
Our monitoring systems have detected a potential issue. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Sep 15, 2020 - 21:40 PDT
This incident affected: INTERNET OF THINGS (Super SIM).