Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Network Latencies Causing Multiple Service Disruptions
      Incident Report for Twilio
      Resolved
      The issue has been resolved. We have mitigated the impact from the service disruption with the exception of Flex Insights. Customers may notice missing Flex Insights events for the next 12 hours from Wednesday Nov 25 11:00 UTC 2020 - Thursday Nov 26 15:00 UTC 2020. These events will be repopulated over the next 12 hours with no missing data.
      Posted Nov 26, 2020 - 20:16 PST
      Monitoring
      We are continuing to see more signs of recovery for REST API while our data streaming provider confirms mitigation of the root issue. Delayed events are now being processed, and we are monitoring to confirm full recovery. We are still investigating impact inn Flex Insights. We will provide another update in 8 hours or as soon as we have more information.
      Posted Nov 26, 2020 - 17:55 PST
      Update
      We are continuing to see more signs of recovery for REST API while our data streaming provider confirms mitigation of the root issue. Delayed events are now being processed, and we are monitoring to confirm full recovery. We are still investigating impact inn Flex Insights. We will provide another update in 8 hours or as soon as we have more information.
      Posted Nov 26, 2020 - 12:00 PST
      Update
      We are seeing more signs of recovery for for REST API while our data streaming provider confirms mitigation of the root issue. Delayed events are now being processed and we expect full recovery to take a few more hours. We will provide another update in 8 hours or as soon as we have more information.
      Posted Nov 26, 2020 - 04:00 PST
      Update
      We are seeing more signs of recovery for affected products while our data streaming provider confirms mitigation of the root issue. Delayed events are now being processed and we expect full recovery to take a few more hours. We will provide another update in 8 hours or as soon as we have more information.
      Posted Nov 26, 2020 - 02:59 PST
      Update
      We have started seeing signs of recovery for affected products while our data streaming provider confirms mitigation of the root issue. Delayed events are now being processed and we expect full recovery to take a few more hours. We will provide another update in 4 hours or as soon as we have more information.
      Posted Nov 25, 2020 - 23:09 PST
      Update
      We have started seeing signs of recovery for affected products while our data streaming provider confirms mitigation of the root issue. Delayed events are now being processed and we expect full recovery to take a few more hours. We will provide another update in 4 hours or as soon as we have more information.
      Posted Nov 25, 2020 - 21:35 PST
      Update
      We have started seeing signs of recovery for affected products while our data streaming provider confirms mitigation of the root issue. Delayed events are now being processed and we expect full recovery to take a few more hours. We will provide another update in 2 hours or as soon as we have more information.
      Posted Nov 25, 2020 - 19:37 PST
      Update
      We are continuing to follow up with our data streaming provider to make progress in recovering the affected services, including Programmable Video, Notify, Event Streams, Flex, Flex Insights, REST API, TwiML Bins and Billing delays for multiple Twilio products. Customers may experience latency in product functionality or data processing delays. We will provide another update in 1 hour or as soon as we have more information.
      Posted Nov 25, 2020 - 18:37 PST
      Update
      We are continuing to work with our data streaming provider to make progress in recovering the affected services, including Programmable Video, Notify, Event Streams, Flex, Flex Insights, REST API, TwiML Bins and Billing delays for multiple Twilio products. Customers may experience latency in product functionality or data processing delays. We will provide another update in 1 hour or as soon as we have more information.
      Posted Nov 25, 2020 - 17:37 PST
      Update
      We are continuing to work with our data streaming provider to make progress in recovering the affected services, including Programmable Video, Notify, Event Streams, Flex, Flex Insights, REST API, TwiML Bins and Billing delays for multiple Twilio products. Customers may experience latency in product functionality or data processing delays or errors when querying completed events (call logs, video rooms and etc). We will provide another update in 1 hour or as soon as we have more information.
      Posted Nov 25, 2020 - 16:35 PST
      Update
      We are continuing to work with our data streaming provider to make progress in recovering the affected services, including Notify, Event Streams, Flex, Flex Insights, REST API, TwiML Bins and Billing delays for multiple Twilio products. We have also identified impacts for Programmable Video when querying completed video rooms via the API. We will provide another update in 1 hour or as soon as we have more information.
      Posted Nov 25, 2020 - 15:37 PST
      Update
      We are continuing to work with our provider to make progress in recovering the affected services, including Notify, Event Streams, Flex, Flex Insights, REST API, TwiML Bins and Billing delays for multiple Twilio products. Customers may experience latency in product functionality or data processing delays. We will provide another update in 1 hour or as soon as we have more information.
      Posted Nov 25, 2020 - 14:35 PST
      Update
      We are continuing to work with our provider to make progress in recovering the affected services, including Notify, Billing, Event Streams, Flex, Flex Insights, REST API and TwiML Bins. Customers may experience latency in functionality or data processing delays. We have observed full recovery for Voice Insights, Transcriptions, Marketplace add-ons, Programmable Chat, WhatsApp, Conversations and Sync. We will provide another update in 1 hour or as soon as we have more information.
      Posted Nov 25, 2020 - 13:34 PST
      Identified
      Twilio's network provider has identified the root cause of the service disruption and we are continuing to work with them to make progress in recovering the affected services, including Notify, Billing, Event Streams, Flex, Voice insights, REST API and TwiML Bins. On the other hand, we have observed full recovery for Transcriptions, Marketplace add-ons, Programmable Chat, WhatsApp, Conversations and Sync. We will provide another update in 1 hour or as soon as we have more information.
      Posted Nov 25, 2020 - 12:32 PST
      Update
      We are continuing to work with our network provider to resolve the network latency issue that’s currently affecting Notify, Billing, Event Streams, Transcriptions, Marketplace add-ons, Flex, Voice insights, REST AP and TwiML Bins. We will provide another update in 30 minutes or as soon as we have more information.
      Posted Nov 25, 2020 - 12:01 PST
      Update
      We are continuing our investigation and have discovered that TwiML Bins is also affected by the incident, along with Notify, Billing, Event Streams, Transcriptions, Marketplace add-ons, Flex, Voice insights and REST API. Customers may experience issues creating or updating TwiML Bins. We will provide another update in 30 minutes or as soon as we have more information.
      Posted Nov 25, 2020 - 11:33 PST
      Update
      We continue to experience delays and latencies for Notify, Billing, Event Streams, Transcriptions, Marketplace add-ons, Flex, Voice insights, and have also observed elevated rate of API failures across multiple endpoints. We may also experience issues posting to Status Page. On the other hand, we are observing a full recovery for Programmable Chat, WhatsApp, Conversations and Sync, and will continue to monitor for system stability. We will provide updates in 30 minutes or as soon as we have information available.
      Posted Nov 25, 2020 - 11:08 PST
      Update
      We continue to experience delays and latencies for Notify, Billing, Event Streams, Transcriptions, Marketplace add-ons, Flex and Voice insights. We may also experience issues posting to Status Page. On the other hand, we are observing a full recovery for Programmable Chat, WhatsApp, Conversations and Sync, and will continue to monitor for system stability. We will provide updates in 30 minutes or as soon as we have information available.
      Posted Nov 25, 2020 - 10:37 PST
      Update
      We continue to experience delays and latencies for Notify, Billing, Event Streams, Transcriptions, Marketplace add-ons, Flex and Voice insights. We may also experience issues posting to Status Page. On the other hand, we are observing a full recovery for Programmable Chat, WhatsApp, Conversations and Sync, and will continue to monitor for system stability. We will provide updates in 30 minutes or as soon as we have information available.
      Posted Nov 25, 2020 - 10:07 PST
      Update
      We continue to experience delays and latencies for Notify, Billing, Event Streams, Transcriptions, Marketplace add-ons, Flex and Voice insights. We may also experience issues posting to Status Page. On the other hand, we are observing a full recovery for Programmable Chat, WhatsApp, Conversations and Sync, and will continue to monitor for system stability. We will provide updates in 30 minutes or as soon as we have information available.
      Posted Nov 25, 2020 - 09:37 PST
      Update
      We continue to experience delays and latencies for Notify, Flex and Voice insights. We are also investigating issues with Billing. We observe fully recovery for Programmable Chat, Conversations and Sync, will continue to monitor. We may also experience issues posting to Status Page. We will provide updates in 30 minutes or as soon as we have information available.
      Posted Nov 25, 2020 - 09:06 PST
      Update
      We continue to experience delays and latencies for Notify, Flex and Voice insights. We're seeing improvements for Programmable Chat and Conversations, but still degraded. We may also experience issues posting to Status Page. We will provide updates in 30 minutes or as soon as we have information available.
      Posted Nov 25, 2020 - 08:35 PST
      Update
      We continue to experience delays and latencies for Notify, Flex, Voice insights, Programmable Chat and Conversations. We may also experience issues posting to Status Page. We will provide updates in 30 minutes or as soon as we have information available.
      Posted Nov 25, 2020 - 08:05 PST
      Update
      We are still experiencing delays and latencies for Notify, Flex and Voice insights. We continue to monitor recovery for Programmable Chat and Conversations. We may also experience issues posting to Status Page. We will provide updates in 30 minutes or as soon as we have information available.
      Posted Nov 25, 2020 - 07:55 PST
      Update
      We are still experiencing delays and latencies for Notify, Flex and Voice insights. We have started seeing recovery for Programmable Chat and Conversations, but continue to monitor to ensure a full recovery. We may also experience issues posting to Status Page. We will provide updates in 30 minutes or as soon as we have information available.
      Posted Nov 25, 2020 - 07:26 PST
      Update
      We are still experiencing delays and latencies for Chat's and Notify's notifications, Flex and Voice insights. We have recovered Programmable Chat and Conversations. We will provide updates in 30 minutes or as soon as we have information available.
      Posted Nov 25, 2020 - 06:55 PST
      Update
      We are still experiencing delays and latencies for Programmable Chat, Chat SDKs, Flex, Notify, Conversations and Voice insights, we will provide updates in 30 minutes or as soon as we have information available.
      Posted Nov 25, 2020 - 06:23 PST
      Update
      We have fully recovered Chat, Synch, Conversation service and no more delays reported
      Posted Nov 25, 2020 - 06:03 PST
      Update
      Our monitoring systems have detected a potential issue with Programmable Chat, Chat SDKs, Flex, Notify and Conversations . Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Nov 25, 2020 - 05:51 PST
      Investigating
      Our monitoring systems have detected a potential issue with Programmable Chat. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Nov 25, 2020 - 05:42 PST
      This incident affected: ACCOUNT SECURITY (Authy 2FA), SERVERLESS (Functions, TwiML Bins, Sync), FLEX (Flex Application Platform, Flex Insights), TWILIO PLATFORM (Billing), DEVELOPER TOOLS (REST API), PROGRAMMABLE VOICE (Recording Transcriptions, Voice Insights), PROGRAMMABLE CHAT, and PROGRAMMABLE MESSAGING (Notify, Conversations).