Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Delays to Venezuela Movilnet Network
Incident Report for Twilio
Resolved
We are no longer experiencing SMS delivery delays to Venezuela Movilnet Network. This incident has been resolved.
Posted Mar 04, 2021 - 16:31 PST
Monitoring
We are observing successful SMS delivery to Venezuela Movilnet for the last 10 minutes. We will continue to monitor to ensure full service recovery. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Mar 04, 2021 - 15:12 PST
Update
We are still experiencing SMS delivery delays when sending messages to the Venezuela Movilnet network. Our engineers continue to work with our carrier partner to resolve the issue. We will provide another update in the next 16 hours or as soon as more information becomes available.
Posted Mar 04, 2021 - 01:07 PST
Update
We are still experiencing SMS delivery delays when sending messages to the Venezuela Movilnet network. Our engineers continue to work with our carrier partner to resolve the issue. We will provide another update in 8 hours or as soon as more information becomes available.
Posted Mar 03, 2021 - 17:12 PST
Update
We are continuing to investigate this issue.
Posted Mar 03, 2021 - 15:26 PST
Update
We are still experiencing SMS delivery delays when sending messages to the Venezuela Movilnet network. Our engineers continue to work with our carrier partner to resolve the issue. We will provide another update in 4 hours or as soon as more information becomes available.
Posted Mar 03, 2021 - 13:12 PST
Update
We are still experiencing SMS delivery delays when sending messages to the Venezuela Movilnet network. Our engineers continue to work with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Mar 03, 2021 - 11:12 PST
Investigating
We are experiencing SMS delivery delays when sending messages to the Venezuela Movilnet network. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Mar 03, 2021 - 10:17 PST
This incident affected: CARRIER NETWORK (SMS, Latin America).