Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Calls failing to Twilio phone numbers in Kenya
Incident Report for Twilio
Resolved
All systems are now performing as designed.
Posted Oct 25, 2019 - 06:50 PDT
Investigating
Our monitoring systems have Identified that calls to some Twilio phone numbers in Kenya are failing. Our engineers are working with our provider to resolve the issue. We will provide an update as soon as we have additional information.
Posted Oct 25, 2019 - 02:09 PDT
This incident affected: CARRIER NETWORK (Voice, Middle East & Africa).