Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Zipwhip Gateway
      Issues related to Zipwhip's Services
        Scheduled maintenance
        System Metrics

        Unable to save Phone Numbers with Studio Flow

        Incident Report for Twilio

        Resolved

        We are no longer experiencing generic errors when saving phone number configurations assigned to a Studio Flow in the Console. This incident has been resolved.
        Posted Jul 24, 2026 - 06:30 PDT

        Monitoring

        The issue causing generic errors when saving phone number configurations assigned to a Studio Flow in the Console are now operating normally. We will continue to monitor for system stability. We'll provide another update in 2 hours or as soon as more information becomes available.
        Posted Jul 24, 2026 - 04:39 PDT

        Update

        Our engineers continue to investigate the issue causing generic errors when saving phone number configurations assigned to a Studio Flow in the Console, and are actively working to deploy a fix. As a temporary workaround, please ensure a valid Status Callback URL is populated when setting your Voice URL to a Studio Flow. We expect to provide another update in 2 hour or as soon as more information becomes available
        Posted Jul 24, 2026 - 02:52 PDT

        Update

        Our engineers are investigating the issue causing generic errors when saving phone number configurations assigned to a Studio Flow in the Console, and are actively working to deploy a fix. As a temporary workaround, please ensure a valid Status Callback URL is populated when setting your Voice URL to a Studio Flow. We expect to provide another update in 1 hour or as soon as more information becomes available
        Posted Jul 24, 2026 - 02:13 PDT

        Investigating

        Our monitoring systems have detected a potential issue with saving phone numbers in studio flow. Our engineers have been alerted and are investigating. We will provide an update when we have more details.
        Posted Jul 24, 2026 - 01:52 PDT
        This incident affected: SERVERLESS (Studio).