Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Outbound delivery issues to Indonesian Indosat handsets
Incident Report for Twilio
Resolved
The incident is now resolved
Posted 3 months ago. Dec 31, 2018 - 21:35 PST
Investigating
We are experiencing an issue with delivery of outbound SMS messages to Indonesian Indosat handsets. Our engineers are working with our carrier partner to resolve the issue and will provide additional information as it becomes available.
Posted 3 months ago. Dec 31, 2018 - 17:34 PST
This incident affected: PROGRAMMABLE MESSAGING (SMS).