We are no longer experiencing SMS delivery delays when sending messages to T-Mobile (formerly Metro PCS Wireless) in the United States of America over a subset of short codes.This incident has been resolved.
Posted Apr 28, 2025 - 00:42 PDT
Update
We are continuing to experience MMS delivery delays and failures to T-Mobile (formerly Metro PCS Wireless) in the United States of America over a subset of short codes. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Apr 27, 2025 - 23:30 PDT
Update
We are continuing to investigate this issue.
Posted Apr 27, 2025 - 22:34 PDT
Investigating
We are experiencing MMS delivery delays and failures to T-Mobile (formerly Metro PCS Wireless) in the United States of America over a subset of short codes. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Apr 27, 2025 - 22:34 PDT
This incident affected: CARRIER NETWORK (MMS Short Code, North America).