Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 20, 2025 - 23:01 PDT
Scheduled
Our SMS carrier partner in Mexico, Peru, Colombia, Honduras, Guatemala, El Salvador, Nicaragua, Ecuador, Costa Rica, the Dominican Republic and Argentina is conducting a series of planned maintenances from 20 May 2025 at 23:00 PDT until 21 May 2025 at 21:00 PDT. During the maintenance window, there could be intermittent delays delivering SMS to and from Mexico, Peru, Colombia, Honduras, Guatemala, El Salvador, Nicaragua, Ecuador, Costa Rica, Dominican Republic and Argentina handsets.
Note, the maintenance will be carried out on each of the following dates and times:
20 May 2025 at 23:00 PDT until 21 May 2025 at 00:00 PDT
21 May 2025 at 20:00 PDT until 21 May 2025 at 21:00 PDT
Posted May 16, 2025 - 18:45 PDT
This scheduled maintenance affected: CARRIER NETWORK (SMS, Latin America).