Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Inbound calls degraded to subset of Canada numbers
Incident Report for Twilio
Resolved
This incident has been resolved.
Posted 2 months ago. Jun 11, 2019 - 06:23 PDT
Monitoring
Our carrier has confirmed that the service has been restored temporarily and working on a full restoration.
Posted 2 months ago. Jun 10, 2019 - 16:11 PDT
Investigating
We have detected an issue receiving inbound calls towards a subset of Canada phone numbers in the Edmonton, Alberta area. We are working with our carrier partners to resolve the issue and will provide an update as soon as possible.
Posted 2 months ago. Jun 10, 2019 - 14:39 PDT
This incident affected: CARRIER NETWORK (Voice, North America).