Status
Welcome to the Twilio status page. Here you will find real-time information about status of our services.
Degraded service for incoming calls to some numbers in Lithuania
Incident Report for Twilio
Resolved
All systems are operating normally at this time.
Posted 8 months ago. Apr 10, 2017 - 06:49 PDT
Investigating
We are currently investigating an outage with some phone numbers in Lithuania being unreachable. We are working with our carrier partner to identify the problem and find a resolution
Posted 8 months ago. Apr 10, 2017 - 04:37 PDT
This incident affected: Programmable Voice (PSTN).