Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS delivery delays from Twilio Pre-Registered Senders ID to Mexico Carrier
      Incident Report for Twilio
      Resolved
      We are no longer experiencing SMS delivery delays when sending messages from Twilio Pre-Registered senders ID to Mexico Carriers.. This incident has been resolved.
      Posted Nov 27, 2021 - 10:49 PST
      Monitoring
      We are observing recovery in SMS delivery delays when sending messages to from Twilio Pre-Registered Senders ID to Mexico Carriers. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Nov 27, 2021 - 09:52 PST
      Update
      We are experiencing SMS delivery delays when sending messages to SMS delivery delays from Twilio Pre-Registered Senders ID to Mexico Carriers. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Nov 27, 2021 - 08:56 PST
      Investigating
      Our monitoring systems have detected a potential issue with SMS delivery delays from Twilio Pre-Registered senders ID to Mexico Carriers. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Nov 27, 2021 - 08:49 PST
      This incident affected: CARRIER NETWORK (SMS Delivery Notifications & Status Callbacks).