Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Degradation - UAE - Pre-registered Alphanumeric Sender IDs
Incident Report for Twilio
Resolved
We are no longer experiencing SMS delivery degradation to the UAE. This incident has been resolved.
Posted Jul 30, 2021 - 04:43 PDT
Update
We are still experiencing SMS delivery degradation to the UAE over a small subset of pre-registered Alphanumeric Sender IDs. Our Sender ID team is currently working with our providers to have this issue resolved. An additional update will be provided in the next 2 hours.
Posted Jul 30, 2021 - 04:21 PDT
Investigating
We are currently experiencing SMS delivery degradation to the UAE over a small subset of pre-registered Alphanumeric Sender IDs. Our Sender ID team is currently working with our providers to have this issue resolved. An additional update will be provided in the next 1 hour.
Posted Jul 30, 2021 - 03:23 PDT
This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).