Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Delays with message delivery status callbacks and delivery status in the messaging API
      Incident Report for Twilio
      Resolved
      This incident has been resolved.
      Posted Apr 07, 2020 - 14:58 PDT
      Monitoring
      We continue to process queued callbacks received during the event and will provide an update when processing has completed. Messaging systems are fully operational.
      Posted Apr 07, 2020 - 13:42 PDT
      Update
      Our engineers have recovered inbound message processing. No inbound message delivery delays are occurring and all queued incoming messages are being delivered. Status callbacks for current inbound messages are fully operational. Queued status callbacks received during the event are being processed. We will provide an update on the queued callbacks as soon as possible.
      Posted Apr 07, 2020 - 13:22 PDT
      Update
      Our engineers continue to work on the issue impacting message status call back delays and delays receiving messages to Twilio numbers. We will provide an update as soon as we have more information.
      Posted Apr 07, 2020 - 11:47 PDT
      Update
      Our engineers continue to work on the issue impacting message delivery status callbacks. We are also seeing delays receiving messages to Twilio numbers. We will provide an update as soon as we have more information.
      Posted Apr 07, 2020 - 10:45 PDT
      Investigating
      Our monitoring systems have detected an issue with message delivery status callbacks and delivery status in the messaging API. Message delivery is not impacted. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Apr 07, 2020 - 10:28 PDT
      This incident affected: PROGRAMMABLE MESSAGING (SMS).