Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Zipwhip Gateway
      Issues related to Zipwhip's Services
        Scheduled maintenance
        System Metrics

        SMS Delivery Delays and Failures From Bitel In Peru To a Subset Of Twilio Shortcode

        Incident Report for Twilio

        Resolved

        This situation has been mitigated for a subset of impacted short codes, for the remaining impacted shortcodes, impacted customers will receive an external communication informing about the situation and next steps. This post will be resolved
        Posted Jul 01, 2026 - 23:57 PDT

        Update

        identified - Twilio customers may be experiencing SMS delivery delays and failures between a subset of Twilio Phone Numbers and network subscribers on multiple networks in Peru. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 2 hour or as soon as more information becomes available.
        Posted Jul 01, 2026 - 19:55 PDT

        Update

        Twilio customers may be experiencing SMS delivery delays and failures between a subset of Twilio Phone Numbers and network subscribers on multiple networks in Peru. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
        Posted Jul 01, 2026 - 17:54 PDT

        Update

        Twilio customers may be experiencing SMS delivery delays and failures between a subset of Twilio Shortcode and Bitel subscribers in Peru. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
        Posted Jul 01, 2026 - 16:52 PDT

        Update

        Twilio customers may be experiencing SMS delivery delays and failures between a subset of Twilio Phone Numbers and network subscribers on multiple networks in Peru. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 24 hours or as soon as more information becomes available.
        Posted Jun 30, 2026 - 18:21 PDT

        Update

        Twilio customers may be experiencing SMS delivery delays and failures between a subset of Twilio Phone Numbers and network subscribers on multiple networks in Peru. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 24 hours or as soon as more information becomes available.
        Posted Jun 29, 2026 - 18:20 PDT

        Update

        Twilio customers may be experiencing SMS delivery delays and failures between a subset of Twilio Phone Numbers and network subscribers on multiple networks in Peru. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 24 hours or as soon as more information becomes available.
        Posted Jun 28, 2026 - 18:14 PDT

        Update

        Twilio customers may be experiencing SMS delivery delays and failures between a subset of Twilio Phone Numbers and network subscribers on multiple networks in Peru. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 24 hours or as soon as more information becomes available.
        Posted Jun 27, 2026 - 18:13 PDT

        Update

        Twilio customers may be experiencing SMS delivery delays and failures between a subset of Twilio Phone Numbers and network subscribers on multiple networks in Peru. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 16 hours or as soon as more information becomes available.
        Posted Jun 27, 2026 - 02:12 PDT

        Update

        Twilio customers may be experiencing SMS delivery delays and failures between a subset of Twilio Phone Numbers and multiple networks in Peru. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 8 hours or as soon as more information becomes available.
        Posted Jun 26, 2026 - 18:05 PDT

        Update

        Twilio customers may be experiencing SMS delivery delays and failures between a subset of Twilio Phone Numbers and multiple networks in Peru. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 4 hours or as soon as more information becomes available.
        Posted Jun 26, 2026 - 13:58 PDT

        Update

        Twilio customers may be experiencing SMS delivery delays and failures between a subset of Twilio Phone Numbers and network subscribers on multiple networks in Peru. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
        Posted Jun 26, 2026 - 11:58 PDT

        Update

        Twilio customers may be experiencing SMS delivery delays and failures between a subset of Twilio Phone Numbers and network subscribers on multiple networks in Peru. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
        Posted Jun 26, 2026 - 10:57 PDT

        Update

        Twilio customers may be experiencing SMS delivery delays and failures from and to a subset of multiple networks in Peru and Ireland to a subset of Twilio Phone Numbers. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 8 hours or as soon as more information becomes available.
        Posted Jun 26, 2026 - 08:14 PDT

        Update

        Twilio customers may be experiencing SMS delivery delays from and to a subset network subscribers to Twilio Peru and Ireland Phone Numbers. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 4 hours or as soon as more information becomes available.
        Posted Jun 26, 2026 - 04:11 PDT

        Update

        Twilio customers may be experiencing SMS delivery delays from and to a subset network subscribers to Twilio Peru and Twilio Ireland Phone Numbers. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
        Posted Jun 26, 2026 - 02:04 PDT

        Update

        Twilio customers may be experiencing SMS delivery delays from and to a subset of network subscribers to Twilio Peru and Ireland Phone Numbers. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
        Posted Jun 26, 2026 - 00:58 PDT

        Update

        Twilio customers may be experiencing SMS delivery delays from network subscribers to Twilio Peru and Ireland Phone Numbers. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
        Posted Jun 26, 2026 - 00:49 PDT

        Update

        Twilio customers may be experiencing SMS delivery delays from network subscribers to a subset of Twilio Peru Phone Numbers. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 8 hours or as soon as more information becomes available.
        Posted Jun 25, 2026 - 23:59 PDT

        Update

        Twilio customers may be experiencing SMS delivery delays from network subscribers in Peru to a subset of Twilio Phone Numbers. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 4 hours or as soon as more information becomes available.
        Posted Jun 25, 2026 - 19:58 PDT

        Update

        Twilio customers may be experiencing SMS delivery delays from network subscribers in Peru to a subset of Twilio Phone Numbers. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
        Posted Jun 25, 2026 - 17:52 PDT

        Identified

        Twilio customers may be experiencing SMS delivery delays from network subscribers in Peru to a subset of Twilio Phone Numbers. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
        Posted Jun 25, 2026 - 16:51 PDT

        Investigating

        Twilio customers may be experiencing SMS delivery delays from Peru Mobile Handsets to a subset of Twilio Phone Numbers In Peru. Our team is actively investigating this issue. We will provide another update in 1 hour or as soon as more information becomes available.
        Posted Jun 25, 2026 - 16:28 PDT
        This incident affected: CARRIER NETWORK (SMS, Latin America).