Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Zipwhip Gateway
      Issues related to Zipwhip's Services
        Scheduled maintenance
        System Metrics

        RCS Compliance Registration Onboarding is failing to load in Console

        Incident Report for Twilio

        Resolved

        Customers trying to register their RCS Sender with Google or a supported country will no longer receive an error page. The team has identified the root cause and deployed a fix. This incident has been resolved.
        Posted Mar 03, 2026 - 16:13 PST

        Update

        We are continuing to investigate this issue.
        Posted Mar 03, 2026 - 16:12 PST

        Update

        Customers trying to register their RCS Sender with Google or a supported country will receive an error page. The team has identified the root cause and we will provide an update in 2 hour or as soon as more information is available.
        Posted Mar 03, 2026 - 15:32 PST

        Update

        Customers trying to register their RCS Sender with Google or a supported country will receive an error page. The team is currently investigating the issue and we will provide an update in 1 hour or as soon as more information is available.
        Posted Mar 03, 2026 - 14:26 PST

        Investigating

        Customers trying to register their RCS Sender with Google or a supported country will receive an error page. The team is currently investigating the issue and we will provide an update in 1 hour or as soon as more information is available.
        Posted Mar 03, 2026 - 14:25 PST
        This incident affected: PROGRAMMABLE MESSAGING (RCS Messaging).