Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Issue to Saudi Arabia/Iraq Zain Mobile Devices
Incident Report for Twilio
Resolved
This incident has been resolved.
Posted 9 days ago. Aug 09, 2019 - 23:05 PDT
Monitoring
We are seeing signs of recovery for traffic. To ensure that service has been fully restored, we will continue to monitor.
Posted 9 days ago. Aug 09, 2019 - 22:30 PDT
Investigating
We have detected an issue that SMS messages sent to Zain mobile devices in both Saudi Arabia and Iraq are not being delivered. We are working with our carrier partners to resolve the issue and will provide an update as soon as possible.
Posted 9 days ago. Aug 09, 2019 - 19:31 PDT
This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).