Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Delays in inbound and outbound US Toll-Free messages
Incident Report for Twilio
Resolved
All systems are opertaional.
Posted 3 months ago. Nov 05, 2018 - 21:59 PST
Monitoring
We are observing recovery of delivery delay for Toll-Free messages. Our engineering team will continue to monitor and provide an update as soon as possible.
Posted 3 months ago. Nov 05, 2018 - 20:38 PST
Update
Our engineers continue to work with carrier partner to resolve this issue. We will provide an update as soon as possible.
Posted 3 months ago. Nov 05, 2018 - 19:38 PST
Update
We have identified an issue with delays in outbound messages from US Toll-free numbers. The delay for outbound messages is 7+minutes. We are still experiencing delays in inbound messages to US Toll-Free numbers. Our engineers are working with our carrier partner to resolve this issue. We will provide an update as soon as possible.
Posted 3 months ago. Nov 05, 2018 - 16:53 PST
Identified
We are experiencing delays in receiving inbound toll-free messaging from our carrier partner for multiple US operators. Our carrier partner continues to troubleshoot the issues but we are currently experiencing messages delays of 11+ minutes for each message from multiple US operators. We will provide an update as soon as possible.
Posted 3 months ago. Nov 05, 2018 - 16:05 PST
This incident affected: PROGRAMMABLE MESSAGING (SMS).