Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Carriers around the world are experiencing capacity issues because of increased demand on their networks due to COVID-19. This may result in voice quality issues, busy signals, or other errors on your phone calls. Twilio continues to monitor the health of the global carrier networks and we are publishing the most up-to-date information on our Worldwide Telephony Network Congestion page.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Flex and Task Router Listing Error
Incident Report for Twilio
Resolved
This incident has been resolved.
Posted Mar 12, 2020 - 09:52 PDT
Update
We are now seeing full recovery. This incident has been resolved.
Posted Mar 12, 2020 - 09:51 PDT
Update
We are continuing to monitor the situation. Customers are seeing recovery, but full recovery is not complete. We continue to monitor the situation and will post any updates here.
Posted Mar 12, 2020 - 09:03 PDT
Monitoring
We have identified the cause of the issue and are currently seeing signs of recovery. We continue to monitor the situation and will post any updates here
Posted Mar 12, 2020 - 08:21 PDT
Investigating
We are observing that some request to list tasks in TaskRouter are returning service unavailable errors. Our engineers are investigating.

We will provide an update when we have more information
Posted Mar 12, 2020 - 06:56 PDT
This incident affected: FLEX (TaskRouter).