Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
US SMS Delivery Failures
Incident Report for Twilio
Resolved
All services are fully operational.
Posted almost 2 years ago. Nov 01, 2017 - 10:45 PDT
Update
Our carrier partner has restored service for US SMS delivery. We will continue to monitor. All services are fully operational.
Posted almost 2 years ago. Nov 01, 2017 - 10:40 PDT
Monitoring
We are seeing recovery in US SMS delivery. Our engineers are continuing to work with our carrier partner to restore service completely. We will provide another update as quickly as possible.
Posted almost 2 years ago. Nov 01, 2017 - 10:26 PDT
Investigating
We are currently experiencing elevated SMS failures in the US. Our engineers are working with our carrier partner to restore service and will provide an update as quickly as possible.
Posted almost 2 years ago. Nov 01, 2017 - 09:53 PDT
This incident affected: PROGRAMMABLE MESSAGING (SMS).