Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delays to Twilio Phone Numbers in Puerto Rico Over a Subset of Long Code
      Incident Report for Twilio
      Resolved
      We are no longer experiencing SMS delivery delays when sending messages to Twilio Phone Numbers in Puerto Rico over a subset of Long Code. This incident has been resolved.
      Posted Oct 15, 2024 - 08:49 PDT
      Monitoring
      We are observing recovery in SMS delivery delays when sending messages to Twilio Phone Numbers in Puerto Rico over a subset of Long Codes. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Oct 15, 2024 - 06:57 PDT
      Update
      We continue to experience SMS delivery delays when sending messages to Twilio Phone Numbers in Puerto Rico over a subset of Long Code. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 8 hours or as soon as more information becomes available.
      Posted Oct 15, 2024 - 06:47 PDT
      Update
      We continue to experience SMS delivery delays when sending messages to Twilio Phone Numbers in Puerto Rico over a subset of Long Code. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 4 hours or as soon as more information becomes available.
      Posted Oct 15, 2024 - 02:47 PDT
      Update
      We continue to experience SMS delivery delays when sending messages to Twilio Phone Numbers in Puerto Rico over a subset of Long Code. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Oct 15, 2024 - 00:47 PDT
      Investigating
      We are experiencing SMS delivery delays when sending messages to Twilio Phone Numbers in Puerto Rico over a subset of Long Code. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Oct 14, 2024 - 23:45 PDT
      This incident affected: CARRIER NETWORK (SMS Long Code, North America).