Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Report Delays to Multiple Networks in the US for a Subset of Short Codes
      Incident Report for Twilio
      Resolved
      We are no longer experiencing SMS delivery report delays when sending to Multiple Networks in the US for a Subset of Short Codes. This incident has been resolved.
      Posted Apr 19, 2024 - 23:58 PDT
      Monitoring
      We are observing recovery in SMS Delivery Report delays to Multiple Networks in the US for a Subset of Short Codes. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2hours or as soon as more information becomes available.
      Posted Apr 19, 2024 - 22:24 PDT
      Update
      We still continue to experience SMS Delivery Report Delays to Multiple Networks in the US for a Subset of Short Codes. Our engineers are investigating, and we will provide another update in 4 hours or as soon as we have more information.
      Posted Apr 19, 2024 - 18:38 PDT
      Update
      We are continuing to experience SMS Delivery Report Delays to Multiple Networks in the US for a Subset of Short Codes. Our engineers are investigating, and we will provide another update in 2 hours or as soon as we have more information.
      Posted Apr 19, 2024 - 16:44 PDT
      Update
      We are experiencing SMS Delivery Report Delays to Multiple Networks in the US for a Subset of Short Codes. Our engineers are investigating, and we will provide another update in 1 hour or as soon as we have more information.
      Posted Apr 19, 2024 - 15:46 PDT
      Investigating
      Our monitoring systems have detected a potential issue SMS Delivery Report Delays to Multiple Networks in the US for a Subset of Short Codes. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Apr 19, 2024 - 15:30 PDT
      This incident affected: CARRIER NETWORK (SMS Short Code, North America).