Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Report Delays to Multiple Italian Networks
      Incident Report for Twilio
      Resolved
      We are no longer SMS delivery report delays when sending messages to multiple networks in Italy. This incident has been resolved.
      Posted Jan 27, 2022 - 04:55 PST
      Monitoring
      We are observing recovery in SMS delivery report delays when sending messages to networks in Italy. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours, or as soon as more information becomes available.
      Posted Jan 27, 2022 - 02:46 PST
      Update
      We are continuing to experience SMS delivery report delays when sending messages to multiple networks in Italy. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours, or as soon as more information becomes available.
      Posted Jan 27, 2022 - 02:25 PST
      Investigating
      We are experiencing SMS delivery report delays when sending messages to multiple networks in Italy. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Jan 27, 2022 - 01:26 PST
      This incident affected: CARRIER NETWORK (SMS, Europe).