Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Billing Region Assignment Currently Experiencing Issues for New Accounts
      Incident Report for Twilio
      Resolved
      This incident has been resolved.
      Posted Nov 14, 2023 - 13:12 PST
      Update
      We are continuing to experience this issue where new accounts are currently not being properly assigned their correct billing region, or currency. All new accounts are defaulting to being default billed out of the US in USD. We will provide another update in 16 hours or as soon as more information becomes available.
      Posted Nov 14, 2023 - 01:00 PST
      Update
      We are continuing to experience this issue where new accounts are currently not being properly assigned their correct billing region, or currency. All new accounts are defaulting to being default billed out of the US in USD. We will provide another update in 8 hours or as soon as more information becomes available
      Posted Nov 13, 2023 - 17:01 PST
      Update
      We are continuing to experience this issue where new accounts are currently not being properly assigned their correct billing region, or currency. All new accounts are defaulting to being default billed out of the US in USD. We will provide another update in 4 hours or as soon as more information becomes available
      Posted Nov 13, 2023 - 12:58 PST
      Update
      We are continuing to experience this issue where new accounts are currently not being properly assigned their correct billing region, or currency. All new accounts are defaulting to being default billed out of the US in USD. We will provide another update in 2 hour or as soon as more information becomes available
      Posted Nov 13, 2023 - 10:57 PST
      Investigating
      New accounts are currently not being properly assigned their correct billing region, or currency. All new accounts are defaulting to being default billed out of the US in USD. We will provide another update in 1 hour or as soon as more information becomes available
      Posted Nov 13, 2023 - 09:51 PST
      This incident affected: TWILIO PLATFORM (Billing).