We are no longer experiencing issues in provisioning new phone numbers, changing configurations on existing phone numbers, releasing phone numbers. This incident has been resolved.
Posted Oct 07, 2025 - 19:54 PDT
Monitoring
We are observing recovery in provisioning new phone numbers, changing configurations on existing phone numbers, releasing phone numbers. This is not impacting voice and messaging traffic. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Oct 07, 2025 - 18:14 PDT
Update
We are expecting our users to see errors while provisioning new phone numbers, changing configurations on existing phone numbers, releasing phone numbers. We will give an update in 1 hour or when more information becomes available.
Posted Oct 07, 2025 - 17:28 PDT
Investigating
Our monitoring systems have detected a potential issue Incoming Numbers API Endpoints. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.