Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Issues to the UAE From a Subset of Pre Registered Sender Ids
      Incident Report for Twilio
      Resolved
      We are no longer experiencing SMS delivery issues when sending messages to the UAE from a subset of pre-registered Sender IDs. This incident has been resolved.
      Posted Jul 25, 2022 - 21:22 PDT
      Update
      We are observing recovery in SMS delivery issues when sending messages to the UAE from a subset of pre-registered Sender IDs. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Jul 25, 2022 - 19:21 PDT
      Update
      We are still experiencing SMS delivery issues when sending messages to the UAE from a subset of pre-registered Sender IDs. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 8 hours or as soon as more information becomes available.
      Posted Jul 25, 2022 - 18:01 PDT
      Update
      We are still experiencing SMS delivery issues when sending messages to the UAE from a subset of pre-registered Sender IDs. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 4 hours or as soon as more information becomes available.
      Posted Jul 25, 2022 - 15:59 PDT
      Update
      We are still experiencing SMS delivery issues when sending messages to the UAE. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Jul 25, 2022 - 14:03 PDT
      Update
      We are experiencing SMS delivery issues when sending messages to the UAE. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Jul 25, 2022 - 13:07 PDT
      Investigating
      Our monitoring systems have detected a potential issue sending OTPs in the UAE. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Jul 25, 2022 - 12:08 PDT
      This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).