Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Super SIM Network Connectivity Issues
Incident Report for Twilio
Resolved
We are no longer experiencing Super SIM connectivity issues. This incident has been resolved.
Posted Feb 17, 2021 - 01:43 PST
Update
Beginning at 7:40am UTC, about 75% of Super SIMs with active data sessions lost connectivity due an issue at a downstream connectivity partner. We began to see recovery around 8:10am UTC. We see about 80% of the disconnected devices have since reconnected. Our engineering team is continuing to investigate the root cause and to monitor the recovery. We will provide another update in 2 hours or sooner once more information becomes available.
Posted Feb 17, 2021 - 01:04 PST
Update
We are experiencing Super SIM connectivity issues with one of our downstream connectivity partners. Our engineering team is actively working with the affected network provider to resolve the issue. We will provide another update in 1 hour or sooner once more information becomes available.
Posted Feb 17, 2021 - 00:29 PST
Investigating
Our monitoring systems have detected a potential issue with active Sessions. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Feb 17, 2021 - 00:02 PST
This incident affected: INTERNET OF THINGS (Super SIM).